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PeopleSoft Query Viewer Overview

PeopleSoft Query Viewer is an end-user reporting tool that allows users to view and run existing
gueries. Use a single mouse click when working with Query. There is no need to double click on fields
or tabs.

e Do not use the back button on the browser when navigating through SFS.

o If the system is processing, there is not a way for you to stop the processing. Pressing the
stop button on the browser or clicking on another tab will likely cause the system to not respond.
You will lose any unsaved data.

o PeopleSoft uses the terms “record” and “table” interchangeably. In this manual, the terms will
mean the same thing, which is a two-dimensional arrangement of rows and columns that holds
data.

e Queries can be either ‘Public’ or ‘Private’. Public queries are available for any user to review,
run or alter. Private queries can only be accessed by the query owner.

Process Frequency Used on an ad hoc basis.
Dependencies Some knowledge of SFS records and data.
Assumptions N/A

Responsible Parties N/A

Alternate Scenarios N/A
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Process Detall
I. Getting Started

Navigation: Reporting Tools > Query> Query Viewer
NavBar: Navigator Q

" <= Reporting Tools *
Recent Places Composite Query >
Query >

There are the three options for Query from the main menu:
o Query Manager- Allows you to create new queries and modify or run existing queries.

e Query Viewer- Allows you only to run existing queries.
e Schedule Query- Allows you to schedule an existing query to run sometime in the future.

II. Running an Existing Query

Navigation: Reporting Tools > Query > Query Viewer

Favorites = Main Menu > Reporting Tools > Query > Query Viewer

Query Viewer

Enter any information you have and click Search. Leave fields blank for a list of all values.

“Search By queryName v begins with

Search Advanced Search

1. Clicking B here Will return the first 300 queries available to you. To access
additional queries it is necegsary to specify search criteria. For additional criteria, click on
the Advanced Search link:
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Query Viewer

Enter any information you have and click Search. Leave fields blank for a list of all values.

v

Query Name begins with
Description beginswith v

Uses Record Name (D8ginswith ¥

Uses Field Name begins with M

Access Group Name | Degins with v a
Folder Name beginswith ¥

*Query Type = User v

v

Owner =

When using the IN or BETWEEN operators, enter comma separated values without quotes. i.e. JOB,EMPLOYEE, JRNL_LN.

Search Clear Basic Search

Enter search information that will limit the results to a manageable number. This search
is useful if you do not know the query name but know a record the query uses.

For example, using the query UW_88 NVS_LIST_OF_ACCOUNTS. You can enter part or
the entire name to get a list of queries. The more data entered, the more refined the results

Query Viewer

Enter any information you have and click Search. Leave fields blank for a list of all values

4.

SFS_RPT

Query Name [Beginswith v [JWW_88_NVS_LIST

Description | begins with v

Uses Record Name | 28gins with A

Uses Field Name |Deginswith v

Access Group Name |Deginswith ¥ Q

Folder Name | begins with v
*Query Type = User v
Owner = v

When using the IN or BETWEEN operators, enter comma separated values without quotes. i.e. JOB,EMPLOYEE,JRNL_LN

Search Clear Basic Search

Search Results

*Folder View |— All Folders - v
Query Personalize | Find | View All | £V | B First ‘4 1-100f 10 '}/ Last
Query Name Description Owner Folder E%‘Lo E;I:e‘io Qm‘\\_to Schedule Definitional References ﬁ:\?c‘r?les
UW_88_NVS_LIST_OF_ACCOUNTS Public NVISION HTML Excel XML  Schedule Lookup References Favorite

There are five Run options for Query Viewer:

a. Runto HTML — Run this report to a HTML format.

b. Run to Excel — Run this report to a Microsoft Excel format.
c. Runto XML — Run this report to an XML format.
d

Schedule — Run this report at some time in the future. The results will show up inthe
Report Manager and can also be e-mailed to you or other users. (See Section IIl)

e. Add to Favorites — Add this query to your list of favorite queries. The query will then
show up on the bottom of the query search pages to find easily. Below is anexample:
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Query Viewer
Enter any information you have and click Search. Leave fields blank for a list of all values.
Search By |Query Name Y1 begins with
Search Advanced Search
Search Results
*Folder View |— All Folders — v
Query Personalize | Find | View All | 2] | ] First ‘4 1-100f 10 "* Last
Query Name Description Owner Folder E%E’ E::etlo ;R(W_to Schedule Definitional References '::\flctl:?tes
UW_88 NVS_LIST_OF_ACCOUNTS Public NVISION HTML Excel XML Schedule Lookup References Favorite

5. This report will show up on the query search pages under the My Favorite Queries section

until it is removed from the list. To remove a query, click =| under the Remove column, or

press Slanninmaiasi-n to remove all favorite queries from the list.

lll. Scheduling a Query
Navigation: Reporting Tools > Query > Query Viewer

When scheduling a query, the query will run through Process Scheduler. You define the time
and day to run the query, along with distribution options.

1. To schedule a query from the Query Viewer, click on the Schedule hyperlink.

Query Viewer
Enter any information you have and click Search. Leave fields blank for a list of all values.
“Search By [ query Name * | begins with UW_88_NVS_LIST_OF_ACCOUNTS
Search Advanced Search
Search Results
*Folder View |— All Folders - v
Query Personalize | Find | View All | £2] | E First ‘&' 1of1 b Lac
Query Name Description Owner Folder E#thLD E::e‘io ;W_m Schedule Definitional References ?g\?o‘rci}tes
UW_ 88 NVS LIST _OF ACCOUNTS Public NVISION HTML Excel XML  Schedule Lookup References Favorite

2. Arun control is needed to schedule a query. A run control is a uniqgue name given to a group
of settings or configuration for output for a specific report.
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Scheduled Query

Find an Existing Value Add a New Value

Private Query/N
Query Name/UW_88 NVS_LIST _OF ACCOUNTS
Run Control IDRUN_SCHEDULED_QUERY]

Add

3. Either select an existing run control or create a new run control for the query. PeopleSoft

defaults to Add a New Value if no Run Controls exist.
4. To searchfor an existing Run Control go to Find Existing Value and click search.

Once you have created a Run Control ID for a specific query, the Scheduled Query screen
will default to

To add a new value, Click Add aNew Vaue
Type in a Run Control ID

5

6

7. Click Add

8. Enter a Description for the query

9. Click = oK

10. Enter a value for any prompts in the query.

11. On the Process Scheduler Request page, you can set up the output for your query. You
can leave the Server Name field blank and it will default to the proper server.

Otherwise, Run scheduled queries on the ‘PSUNX’ server. Choose ‘PSUNX’ from the
Server Name drop down menu.

12. Select the time that PeopleSoft should run the query, if different than the default time.

13. You can also set a recurrence, if you would like a report run more than once on aschedule.
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Process Scheduler Request

User ID 00913865

Server Name
Recurrence

Time Zone

Process List
Select Description

v PSQUERY

OK Cancel

Run Control ID RUN_SCHEDULED_QUERY

A Run Date |12/10/2018 [+
v Run Time 4:29:47PM

Process Name
PSQUERY

Process Type *Format

TXT M

*Type

Application Engine | Web A

14. Select a value from the output Type dropdown menu....you can also
select an output format, using the values in the Format dropdown menu.

Reset to Current Date/Time

Help

Distribution

Distribution

15. When using the ‘Email’ option (value under the Type dropdown menu), click onthe
Distribution link to set the e-mail options. You will see the Distribution Detail screen.

16. Under the Email Only section, add an e-mail subject, message text and email address(es) to

the Email Address List box. The e-mail will send an attachment/link to the query results in
the Report Manager.
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Distribution Detail

Help
Process Name PSQUERY
Process Type  Application Engine
Folder Name M
Retention Days 90
Email Only
Email Subject Email With Log: Email Web Report:
ra
Message Text
4
Email Address List
A
Distribute To
*ID Type *Distribution ID
User v | 00913865 Q [+ [=]
OK Cancel

17. The default distribution in the Distribute To section is only to the user that runs the query.
If additional users need to view the query in the Report Manager, add them to the
Distribute To section by clicking the 4], Any users (or roles) selected here will be able to
view the query in the Report Manager. Selecting a role will allow anyone with that role to

view the query results. NOTE: You cannot add or lookup a user without first choosing a
value from the ID Type dropdown menu.

18. Click " 2% You will be taken back to the Process Scheduler Request screen.

19. Click I o

20. To view your scheduled report, navigate to the Report Manager. You should see a link to
the Report Manager on the Schedule Query screen. If you do not have a link, you can
navigate to the Report Manager as follows:

Reporting Tools > Report Manager
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Schedule Query

Run Control ID RUN_SCHEDULED_QUERY

Query Name UW_88 NVS_LIST_OF ACCOUNTS

“Description Run Query

Process Monitor

21. Your report can be found on the Administration tab under the Details link:

List Explorer Administration Archives
View Reports For
Folder hd Instance
Name Created On
Reports
Report Report Description

1 Run Query RUN QUERY

to
[z1] | Last
Personalize | Find | View All | [Ed | E
Folder Name g:::ﬁll-len‘,:‘i: n
e

Refresh

v

First 4

Report
ID

8093360

22. To schedule a query from the Main Menu, navigate as follows:
Reporting Tools > Query > Schedule Query

NavBar: Navigator

<  Query

Recent Places

Query Manager

»

Query Viewer

My Favorites

Schedule Query

23. Follow steps 2- 19 as outlined above.
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Scheduled Query

Enter any information you have and click Search. Leave fields blank for a list of all values.

Find an Existing Value Add a New Value
Search Criteria

Search by: | Run Control ID ¥ |begins with RUN_SCHEDULED_QUE

Case Sensitive

IV. Internet Explorer Settings for Query Download to Excel

Depending on the settings on your computer, when you run a query to Excel, it may or may not
open in the Internet Explorer browser window. If Excel does open in the browser window, Excel
functionality is not available. This setting is defined in Internet Explorer.
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To adjust the settings:

1. Open an Internet Explorer Window.

2. Choose “Tools” from the menu in the upper right hand corner.

bl

][4

D &

2]

|l
L=3

<>

&

Diagnose Connection Problems...

Reopen Last Browsing Session

Pop-up Blocker
Manage Add-ons

Work Offline

Compatibility View
Compatibility View Settings
Full Screen

Toolbars

Explorer Bars
Developer Tools
Suggested Sites

OneNote Linked Notes
Send to OneNote

Internet Options

% v B v [ d= v Pagev Safetyv(-gw

F11

F12

3. Click Internet Options.

4. Inthe Internet Options screen,

. Custom level...
& Click | Customievel... |

click | Seeurty |
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Shared Financial System
e — ]

General | Security | privacy | Content | Connections | Programs | Advanced |

Select a zone to view or change security settings.

@ & v O

Internet  Localintranet Trustedsites  Restricted
sites

Internet
Sites

0 This zone is for Internet websites,
except those listed in trusted and

restricted zones.

Security level for this zone

I Allowed levels for this zone: Medium to High I
Medium-high
- Appropriate for most websites
=) - Prompts before downloading potentially unsafe
content

- Unsigned ActiveX controls will not be downloaded

Enable Protected Mode (requires restarting Internet Explorer)
Custom level... | | Defaultlevel

[ Reset all zones to default level ]

[ ok ][ cancel Apply

6. Scroll down to the “Downloads” heading.

7. Under “Automatic prompting for file downloads”, choose the “Enable” radio button.
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8. Clle ............... Y .

9. Click '

:.Security Setﬁ-r-\gs - Internet g g]

Settings

@ Enable -
() Prompt
|&# Downloads
@3 Automatic prompting for file downloads
(7)1 Nisahle
®
9% rie downioad I
() Disable
@ Enable
@(g Font download
(7) Disable
@ Enable
) Prompt
(% Enable .NET Framework setup
() Disable
@& Enzhla
< | 1 | »

*Takes effect after you restart Internet Explorer

Reset custom settings
Reset to: [Med‘um-high (default) vl [ Reset... ]

ok J[ concel |

@ Are you sure you want to change the settings for this zone?

[ Yes ] [ No
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Shared Financial System

i'
General | Security | Privacy | Content | Connections | Programs | Advanced

Select a zone to view or change security settings.

@ & / ©

Internet  Local intranet Trusted sites  Restricted
sites

Internet

0 This zone is for Internet websites, ~
except those listed in trusted and
restricted zones.

Sites

Security level for this zone

Custom

Custom settings.
- To change the settings, dick Custom level.
- To use the recommended settings, dick Default level.

Enable Protected Mode (requires restarting Internet Explorer)
| customlevel.. || Defautlevel |

[ Reset all zones to default level ]

[ ok |[ concel || Aty |

)

Apply
P

10. Click *
11. Click *

12. Excel will now open in a new window when opened.
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